Centos使用yum出现/usr/local/lib/liblzma.so.5: version `XZ_5.1.2alpha' not found (required by /lib64/librpmio.so.3)

  • 发布时间:2017-07-26 13:30:28
  • 作者:数据之巅
  • 标签:centos,linux

在CentOS上面使用yum出现以下情况:

/usr/local/lib/liblzma.so.5: 
    version `XZ_5.1.2alpha' not found (required by /lib64/librpmio.so.3) Centos使用yum出现/usr/local/lib/liblzma.so.5: version `XZ_5.1.2alpha' not found (required by /lib64/librpmio.so.3) 


这种情况是因为安装编译了xz库,动态库加载顺序/usr/local/lib 大于  /usr/lib64 。卸载掉自行编译安装的xz库就可以解决(操作前请备份相关操作)